Blinkers going haywire in extreme cold. - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-25-2019, 09:10 AM Thread Starter
Junior Member
 
Join Date: Dec 2017
Location: Crystal, Mn
Chapter: Midwest
Year: 2003
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 42
Rep Power: 0
 
Trader Score: 0 reviews
Blinkers going haywire in extreme cold.

This morning when I drove to work it was -7 degrees and it made my blinkers go haywire. Sometimes they would do nothing at all, sometimes I would hear them click fast with no dash light and sometimes they would work fine. This is on both sides. By the time I got to work and everything was warmed up everything was working fine so I couldn’t check to see how the actual lights were responding during this strange behavior. I’m concerned because it looks like we’re going to be in a deep freeze for a while and in the -20s next week so this will probably crop up again. Any ideas what the problem could be?
haneybd87 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-13-2019, 01:00 PM
Junior Member
 
AngelArs's Avatar
 
Join Date: Feb 2019
Location: Ohio
Chapter: Northeast
Year: 2004
Model: Ford Taurus
Engine: 3.0L 24v Duratec V6
Posts: 90
Rep Power: 1
 
Trader Score: 0 reviews
Extreme cold (and heat) can effect electrical contacts. The extreme cold might have effected a part that is worn and about to go bad. I wouldn't worry about it at this time, but keep an eye out for it. Intermittent electrical issues are very hard to trace down anyway.
AngelArs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Taurus Fans work but blows cold on hot and hot on cold Casey Buttrey Maintenance and Repair 5 08-01-2018 01:02 PM
Start-stall only in extreme cold gtarist Maintenance and Repair 4 01-08-2018 02:30 PM
ROUGH idle on cold start and until warm IkeNewton Maintenance and Repair 10 04-27-2016 05:47 PM
Strange problem with battery for many years. Won't start in cold at all. RavenLX Maintenance and Repair 23 01-26-2014 03:34 AM
Extreme cold weather and brake function melrosemiss Suspension, Handling and Brakes 10 01-11-2014 11:30 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome