2003 Wagon Radio Replacement - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-25-2018, 06:06 AM Thread Starter
Junior Member
 
Join Date: Apr 2018
Location: Rochester, NY
Chapter: Northeast
Year: 2003
Model: Ford Taurus Wagon
Engine: OTHER
Posts: 2
Rep Power: 0
 
Trader Score: 0 reviews
2003 Wagon Radio Replacement

So I am trying to replace the stock radio in my 2003 SE wagon and I'm running into some trouble.

Here's the parts I have:

Boss 506UA MP3 Compatible CD AM/FM Receiver (spent a whole month in my fiancee's Cavalier before she totalled it)

American International FM-K578 Mounting Kit

Metra 70-5513 Ford Premium Sound System Harness to Bypass or Integrate Factory Audio Components with Aftermarket Audio Components (heckuva name - only purchased after some issues, read on...)

The original radio was an AM/FM CD player. No CD changer, no tape deck.

I soldered the wiring harness from the mounting kit to the appropriate wires on the new radio. Ran the wiring harness back to the RCU only to find that both the wiring harness and the plug on the RCU both have male ends. Thought I could solve this by removing the male end of the new wiring harness and soldering it to the matching pins of the female plug that originally plugged into the RCU. However, this did not work. When I started the car up, the new radio turned on, the climate controls worked, but there was no sound. I am sure the radio was getting signal from the radio, CD, and aux plug because the display showed the audio levels. I checked the fuse box to find that the 20 amp fuse for the radio was blown. Replaced that, still no joy.

It was then I learned through some googling that I should bypass the RCU - enter the Metra bypass adapter. The instructions seemed simple enough to me - the other plug in the RCU should be unplugged and plugged into the Metra adapter. One end plugged right into the female plug that I soldered to the mounting kit wiring harness, but the other end did not match either of the other jacks on the RCU. I assumed that the other plug was for the speakers, but the colors do not match the colors for the speaker wires that I soldered to the wiring harness.

What is going on here? What am I missing? What are those other plugs on the RCU? Do I need a different adapter? I have tried finding info on the RCU on the web, but I am not having any luck. Can my choice of radio even bypass the RCU? Any help would be appreciated, I'd love to sort this out before taking it to a shop. I did take some pictures if that helps, let me know and I will post them.
Thanks!
aruption is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacement Power Antenna Mast on 2003 LS Wagon estrauss11 Electronics, Security, Audio and Visual 4 09-27-2016 04:54 PM
2003 Wagon Suspension Upgrades wbishop01 Suspension, Handling and Brakes 0 08-29-2016 02:14 PM
2003 radio replacement - trunks and blower switches WhatamIdoing Electronics, Security, Audio and Visual 2 06-21-2015 10:14 PM
Radio Replacement 98 Ford Taurus Cenzo22 Electronics, Security, Audio and Visual 4 12-18-2013 01:17 PM
2003 tarus wagon rocker replacement rawky559 Maintenance and Repair 1 06-18-2013 12:21 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome