Questions about replacing radio. - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 08-03-2017, 04:54 PM Thread Starter
Junior Member
 
Join Date: Aug 2017
Location: Seattle
Chapter: West Coast
Year: 2000
Model: Ford Taurus
Engine: 2.0L EcoBoost I4
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
Questions about replacing radio.

Hello there, I'll get right into it.
The stock radio for my 2000 taurus started staying on after the keys were removed from the vehicle, and the buttons all lost function including the power button to turn it off. I started leaving it off if the buttons ever started working for a second to avoid battery drain. After a few days to a week, it just died entirely, no clock or anything.

I took my car in to a mechanic for an unrelated issue with a fan, and asked them to take a look at the radio as well, they told me that they couldn't find a reason that it shouldn't work, and to just replace the radio. I didn't want to keep the original stock style, I wanted something with an AUX cord so I didn't have to rely on my cd changer anymore. I purchased an American International FMK578 installation kit, as well as a used pioneer DEH-2000MP, and started to put it all together.

I removed the stock radio, moved the air conditioning controls to to the new unit, wired the radio for power through the FMK578 harness, that wasn't too bad.
So if I were to plug this unit back into the car as it stands now, the radio would have power and the ac would work, but the radio would not be connected to the speakers or antenna.

The installation kit comes with a second wire harness designed to be fed into the trunk and connected to the amplifier, and an antenna cable; This is where I would like some advice before I proceed and damage systems.

1) The new harness going into the amplifier has a short yellow and black wire, with butt connectors pre-attached and crimped on one side. Where am I supposed to get power for these? There are no loose wires back here, the best idea I've had (I think) is to sever the old yellow/black wire from the old plug that I am replacing, since that would maintain the original path of current from wherever the line originates to the amplifier. Should I proceed with this idea?

2) Does the antenna cable go from my radio into the amp? Or into the antenna cable plugged into the amp? Or something more? The antenna cable coming out of the amp is less than a foot long, and connects to a small box with another antenna cable coming out, and another small wire. I'll attach a picture of this at the bottom(sorry its so big); I do not understand the function of that small box.

3) How do I route these speaker and antenna cables from the trunk to the inside of the car, without drilling any holes? Is there any way that I could get these wires to come out under my back seat? That would be perfect.

4) There are some unused wires and ports, and I would like to make sure that's intentional.
The wire harness provided in the kit that connects to the amplifier has a blue wire which is for power antenna, right? Pretty sure my antenna is always up, so that's ok.
The radio has a blue/white wire, with an insulated connector on the end, the kind that grabs a metal plate. There was no blue/white wire on the harness going to the amp, and all the research I've done tells me that an amp needs a blue/white wire, I'm not sure if my stock amp is different or what but I get the feeling that it won't turn on even if I figure out the power concern in issue #1

5) I just want to make sure my wire connects are done correctly here, in case I've missed something or made an error, so I'll list what I've done or plan to do:
Radio wire harness red/yellow/black connected via the wire harness on the FMK578, which came with those color loose wires pre-stripped
Radio wire harness 8 speaker wires will be connected to the 8 speaker wires on the long harness for the amp in the trunk (no rca, is that correct?)
The amp then connects those wires to the corresponding speakers? I hope?
The man I got my radio from included an inline fuse wire with a 6 amp fuse, and told me that it could be wired in series with the yellow on the radio harness for extra protection, but I chose to leave that out due to my radio itself having a fuse, and that I have all kinds of automotive fuses laying around, but no glass fuses to replace it if ever it should fail, causing me 4-6 business days of no radio while I wait for the replacement part. Hope that was ok.

Sorry that this is such a long read, I realistically don't expect to have all of my questions answered, but I will be extremely thankful to anyone who has continued to read this far and has any sort of advice for me to carry out this project. I'm quite new to this sort of thing, and I've enjoyed the learning process so far. I'll do whatever I can on my end to be as clear as possible; I can take more pictures or provide any other information about the project.


here's the picture of my trunk amp as referenced in question #2
CShaggy is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-07-2017, 01:30 AM Thread Starter
Junior Member
 
Join Date: Aug 2017
Location: Seattle
Chapter: West Coast
Year: 2000
Model: Ford Taurus
Engine: 2.0L EcoBoost I4
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
Welp, I finished the job myself so I might as well answer these questions for anyone else that attempts this in the future.

1) There's no need to connect those power wires to anything, the harness supplied with the kit bypasses the amplifier, it doesn't connect to it.
2) The antenna bypasses the small box, I never did figure out what that was for.
3) Remove the back seat bench, and then remove the two bolts holding the top portion.
4) Leave those wires alone, cap them off if they are unprotected.
5) I sure hope, but everything is working fine

I'm enjoying my new radio now, it was a very simple job once I stopped over complicating it.
CShaggy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
aftermarket radio install bill schartiger Electronics, Security, Audio and Visual 3 04-24-2016 01:07 AM
Ez Topic Finder qwertz9586 Introduction Forum 10 06-11-2015 05:41 PM
3rd Gen Radio Troubleshooting Securitygate Electronics, Security, Audio and Visual 4 03-16-2015 10:30 AM
Radio Replacement 98 Ford Taurus Cenzo22 Electronics, Security, Audio and Visual 4 12-18-2013 01:17 PM
Replacing A/C general questions liquid_force Maintenance and Repair 3 07-01-2013 10:07 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome