A/C warmer on driver's side and HVAC randomly switches off - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 05-17-2019, 07:59 PM Thread Starter
Junior Member
 
Join Date: Mar 2016
Location: NY
Chapter: Northeast
Year: 2008
Model: Ford Taurus
Engine: 3.5L Cyclone V6
Posts: 49
Rep Power: 0
 
Garage
Trader Score: 0 reviews
A/C warmer on driver's side and HVAC randomly switches off

I just got a 2012 Taurus SEL with 68K. I took it on a 500 mile trip. It was hot today and I put the A/C on. It works but it blows slightly warmer on the driver's side. Both knobs are all the way on cold. A/C is on with recirculation and fan on high. It switched itself off when I went to pull away. It did this about 4 times (maybe the A/C needs recharged and this is a self protect feature?) I replaced the cabin air filter and nothing. I'm leaving to go back home Sunday. It's another 500 miles and it's going to be about 93. What's the issue here?
Cool Wagon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Locate HVAC Low Side Port RonT Maintenance and Repair 1 05-19-2018 07:42 AM
2011 HVAC Driver side warmer on AC Turbod 5th and 6th Gen Maintenance and Repair 2 09-28-2017 02:49 PM
Gen 4 passenger side window HVAC airflow Ocelot Maintenance and Repair 2 10-17-2016 07:51 AM
2010 SHO Drivers Side - No Heat hhilljr 5th and 6th Gen Maintenance and Repair 0 03-11-2016 08:30 AM
Several issues with 2008 Taurus HVAC bitshift32 5th and 6th Gen Maintenance and Repair 6 07-15-2015 04:32 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome