2013 3.5 Coolant Leak - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 03-28-2019, 06:56 PM Thread Starter
Junior Member
 
Join Date: Dec 2018
Year: 2013
Model: Ford Taurus Police Interceptor
Engine: 3.5L Ti-VCT V6
Posts: 4
Rep Power: 0
 
Trader Score: 0 reviews
2013 3.5 Coolant Leak

I'm losing coolant very slowly. It's not the pump. The sheath on my hose from the overflow is getting saturated with coolant. I replaced the hose thinking that was the culprit, but the leak continues and is still collecting at the lowest point of the hose. The only parts above the leak are the reservoir and the hose clamp. I have never seen a spring clamp lose tension, so I'm wondering if anyone has ever had to replace their reservoir? Are there any other points that would allow a leak path near the bottom of the reservoir that I'm not seeing?

Thanks in advance.
sugarmamaspickle is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant Leak Mystery Continues ??? user9797 Maintenance and Repair 12 02-01-2017 12:09 AM
Coolant leak remains after replacing heater hose assembly girafferson Maintenance and Repair 3 11-04-2016 03:51 PM
Mystery coolant leak Cobrargc Maintenance and Repair 20 01-09-2016 04:40 PM
ERG? or DPFE? causing high RPMs CBrotherton Maintenance and Repair 6 06-29-2013 11:47 PM
strange coolant leak peterf1992 Maintenance and Repair 9 04-14-2013 10:55 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome