08 Taurus hvac issue - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 12-09-2013, 09:24 PM Thread Starter
Junior Member
 
ceejpea's Avatar
 
Join Date: Dec 2013
Chapter: Northeast
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
08 Taurus hvac issue

I have a 2008 ford Taurus sel that is having hvac issues. I purchased the car almost 2 years ago and every so often I would get a loud clicking noise (drivers side dash) when I started the car and the a/c or heat was on. Then after about 10 seconds it would stop. Well now it clicks about 10 seconds every time I start the car but sounds really low and the air only blows out of the vents in the dash. The heat and a/c work great but I can not get it to change from the vents to the floor or the defrost settings. I have a dual climate control EATC unit and have done the self test and get a code of 10 03. I have not been able to find what this code means anywhere. I think it may be the mode door actuator has gone bad. If this is the case what do I have to do to replace it and what can I do to confirm this is the problem. Thanx
ceejpea is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-10-2013, 10:15 PM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 22,394
Rep Power: 112
     
Trader Score: 1 reviews
Clicking sure sounds like a bda issue. May pm member Taurus Bear.
sheila is offline  
post #3 of 5 (permalink) Old 12-12-2013, 07:44 PM Thread Starter
Junior Member
 
ceejpea's Avatar
 
Join Date: Dec 2013
Chapter: Northeast
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
I pmed him Thanx
ceejpea is offline  
 
post #4 of 5 (permalink) Old 05-01-2019, 02:59 PM
Junior Member
 
Join Date: Apr 2019
Posts: 8
Rep Power: 0
 
Trader Score: 0 reviews
Could you briefly explain how you did the self test and how long it took the test to complete? I was able to get a test started today, the screen was all lit up with 88.8 showing which I am told means the test is running, but I let it run for over 30 minutes and never completed.
Richman is offline  
post #5 of 5 (permalink) Old 05-01-2019, 03:12 PM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 22,394
Rep Power: 112
     
Trader Score: 1 reviews
^ Iirc, 888= everything checks out?
sheila is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 Ford Taurus Transmission Issue Allen90 Maintenance and Repair 4 04-25-2017 06:53 PM
08 Taurus sel HVAC issue ceejpea Maintenance and Repair 0 12-09-2013 09:02 PM
Weird Transmission issue or just Taurus quirkiness???? pimpninja Maintenance and Repair 3 09-09-2013 05:27 PM
Looking at a 92 Taurus w/56k w/overheating issue dartheyeball Engine and Drivetrain 19 08-04-2013 09:56 AM
2000 Taurus Not typical Door Ajar Issue mrpooky Maintenance and Repair 8 04-06-2013 05:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome