2015 Taurus SHO - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 07-17-2019, 03:12 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Location: Maryland
Chapter: Northeast
Year: 2015
Model: Ford Taurus SHO
Engine: 3.5L EcoBoost V6
Posts: 8
Rep Power: 0
 
Trader Score: 0 reviews
2015 Taurus SHO

My rear defrost has stopped working, but light comes on and mirrors work. All the grid wires seem ok, so think maybe the wire connector tab came loose or is broke. Anyone now where it connects before I start removing trim to find it? Thanks

Last edited by jag1959; 07-18-2019 at 08:05 PM.
Vince McGowan is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-17-2019, 06:22 PM
Play Nice or Don't Play

 
jag1959's Avatar
 
Join Date: Jun 2011
Chapter: Northeast
Year: 1998
Model: Ford Taurus SHO
Engine: 3.4L Yamaha V8
Posts: 14,859
Rep Power: 120
       
Trader Score: 0 reviews
Welcome to TCCA, I'd start with fuses and relays. If you need further assistance please post in the appropriate forum.

It's SHO time!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jag1959 is offline  
post #3 of 7 (permalink) Old 07-17-2019, 11:49 PM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 22,372
Rep Power: 112
     
Trader Score: 1 reviews
Welcome Vince! If you haven't already, may want to check out the Ecoboost Owner Forums and the Ecoboost Performance Forum. Also, check out member bpd1151's (Mike) garage and posts on here.

Last edited by sheila; 07-18-2019 at 05:05 PM.
sheila is offline  
 
post #4 of 7 (permalink) Old 07-18-2019, 02:47 PM
Senior Member
 
TollKeeper's Avatar
 
Join Date: Aug 2018
Location: Denver, Colorado
Chapter: Pacific Northwest
Year: 2005
Model: Mercury Montego
Engine: 3.0L 24v Duratec V6
Posts: 716
Rep Power: 4
 
Garage
Trader Score: 0 reviews
Welcome!

Please be sure to post your question in the forum related to your car. The intro forums dont get much, if any, traffic, and you are not likely to get help in the introductions area.

Brian - Carpe Diem

2005 Mercury Montego 52k
2004 GMC Envoy XUV 182k
2001 Pontiac Aztek GT AWD 120K
TollKeeper is offline  
post #5 of 7 (permalink) Old 07-18-2019, 04:31 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Location: Maryland
Chapter: Northeast
Year: 2015
Model: Ford Taurus SHO
Engine: 3.5L EcoBoost V6
Posts: 8
Rep Power: 0
 
Trader Score: 0 reviews
Thanks all. I would only let me post here first, but I will repost. Fuses are good as mirrors are working.
Vince McGowan is offline  
post #6 of 7 (permalink) Old 07-19-2019, 02:31 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Location: Maryland
Chapter: Northeast
Year: 2015
Model: Ford Taurus SHO
Engine: 3.5L EcoBoost V6
Posts: 8
Rep Power: 0
 
Trader Score: 0 reviews
I don't see any Ecoboost forums listed
Vince McGowan is offline  
post #7 of 7 (permalink) Old 07-19-2019, 10:27 PM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 22,372
Rep Power: 112
     
Trader Score: 1 reviews
Did you google Ecoboost Owner Forums and/or Ecoboost Performance Forum? May pm member bpd1151 on here.
sheila is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Taurus rear shock absorbers Limited413 5th and 6th Gen Suspension, Handling and Brakes 11 06-07-2019 01:44 PM
2013 Taurus Rear Power Window Shade Problem..how to diagnose? PredatorVI 5th and 6th Gen Maintenance and Repair 3 08-10-2017 05:59 PM
Spoiler Question 2015 Taurus Backwardsmann 5th and 6th Gen Aesthetics, Interior, Wheels and Tires 3 02-21-2017 09:49 PM
2013 taurus rear rotors jerry in pitt pa 5th and 6th Gen Suspension, Handling and Brakes 12 11-17-2015 08:05 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome