HELP No charge! - Taurus Car Club of America : Ford Taurus Forum
Register Home Forums Active Topics Topic Finder Photos Members List Search Today's Posts Mark Forums Read Auto EscrowAuto Loans
TaurusClub.com is the premier Ford Taurus Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 11-13-2012, 07:38 PM   #1 (permalink)
Junior Member
 
Member Number: 51189
Join Date: Nov 2012
Chapter: Northeast
Drives: 1995 Ford Taurus SHO 3.0L
Visit: My Garage
Posts: 13
Trader Score: 0 reviews
Rep Power: 0
cuzimmaG is an unknown quantity at this point
Default HELP No charge!

Hi, I'm new to the SHO scene but have worked on vehicles for years. I have a 1995 Ford Taurus SHO 3.0L MTX. I can't seem to keep the car running. I have bought a new alternator and battery as well as idler pulley. The car will still not charge anything. I took the alternator out got it tested it read 17.5 volts. Just to make sure i had it exchanged. Got the new part and still no luck. I've tested all my leads and everything seems to be working fine. What could the problem possibly be? No fuses are blown no major draws no shorts.. I'm totally stumped. Any help would be appreciated.
cuzimmaG is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-13-2012, 08:10 PM   #2 (permalink)
Technical Advisor
 
behlinla's Avatar
 
Member Number: 14275
Join Date: Dec 2007
Location: Wisconsin
Chapter: Midwest
Drives: A blue car
Visit: My Garage
Posts: 7,524
Trader Score: 0 reviews
Rep Power: 81
behlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond repute
Default

Check the alternator fuse #26 (30A) in the engine bay. It sounds like you're not getting any current to the field coil, so the alternator can't charge. Also make sure the battery light is lighting up on the dash when KOEO.
behlinla is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 08:25 PM   #3 (permalink)
Junior Member
 
Member Number: 51189
Join Date: Nov 2012
Chapter: Northeast
Drives: 1995 Ford Taurus SHO 3.0L
Visit: My Garage
Posts: 13
Trader Score: 0 reviews
Rep Power: 0
cuzimmaG is an unknown quantity at this point
Default

Checked all fuses are fine.. And i apologize with posting on both sections. I have read the link wrong and unaware on how to delete at this time lol.
cuzimmaG is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 09:18 PM   #4 (permalink)
Technical Advisor
 
behlinla's Avatar
 
Member Number: 14275
Join Date: Dec 2007
Location: Wisconsin
Chapter: Midwest
Drives: A blue car
Visit: My Garage
Posts: 7,524
Trader Score: 0 reviews
Rep Power: 81
behlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond repute
Default

All further posts will be on the other thread: HELP No Charge!
behlinla is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:13 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2