04 taurus check engine light - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 11-07-2011, 07:35 AM Thread Starter
Junior Member
 
Join Date: Nov 2011
Chapter: Northeast
Posts: 2
Rep Power: 0
 
Trader Score: 0 reviews
Angry 04 taurus check engine light

good morning to all. i am very new to these forums. i have an 04 taurus that has a check engine light on it... i went to pepboys to have them read the codes. based on that i have replaced coil pack,plugs and wire, ect. i finally took it to kwik kar lube and he was unable to finish his evaluation on it but said it started dumping alot of gas into the engine. when he took it on a test drive, he said all of the O2 sensors flat lined on him and then came back up and started running just fine. he thinks its a possible electrical issue. any thoughts
s26847 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-07-2011, 07:42 AM
Junior Member
 
Join Date: Nov 2011
Chapter: Northeast
Posts: 50
Rep Power: 10
 
Trader Score: 0 reviews
Do you know what code it is showing?
bobkyle2 is offline  
post #3 of 5 (permalink) Old 11-10-2011, 08:58 AM Thread Starter
Junior Member
 
Join Date: Nov 2011
Chapter: Northeast
Posts: 2
Rep Power: 0
 
Trader Score: 0 reviews
dont know what the codes were.... i drove it today to work, on my way, the idle dropped down and started to idle rough. not sure whats going on.
s26847 is offline  
post #4 of 5 (permalink) Old 11-10-2011, 09:55 AM
Technical Advisor
 
Join Date: Feb 2007
Location: Milwaukee, WI
Chapter: Midwest
Year: 2005
Model: Ford Taurus
Engine: 3.0L 24v Duratec V6
Posts: 5,754
Rep Power: 71
     
Trader Score: 0 reviews
We can not help you at all without knowing the code or codes!!!!!!

05 Taurus SEL Duratec - my daily driver
04 Taurus SES Duratec - wifes car
95 Taurus GL Vulcan winter car
Toy #1 - 86 Tbird 5.0 (original owner) - LOTS of mods
Toy #2 - 88 Tbird Turbo Coupe - LOTS of mods
67 Honda 450 Super Sport - completely customized
Jeff K is online now  
post #5 of 5 (permalink) Old 11-10-2011, 04:14 PM
Junior Member
 
Join Date: Dec 2008
Location: SF Bay Area, CA
Chapter: West Coast
Posts: 93
Rep Power: 16
 
Trader Score: 0 reviews
without knowing the codes..kinda sounds like lazy o2 sensors and/or a vacuum leak causing a rich condition.
I doubt electrical, but wouldn't hurt to check wires for scathed insulation.
ericf is offline  
Sponsored Links
Advertisement
 
Reply
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome