Speedometer Not Working... - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 02-15-2005, 06:08 PM Thread Starter
Member
 
gamefanatic's Avatar
 
Join Date: Apr 2004
Posts: 396
Rep Power: 0
 
Trader Score: 0 reviews
Yesterday I was doing some shopping. Everything was fine, but one time we got into the car and I started it up. Then I started to take off I noticed that the speedometer needle was not moving at all. Then I decided to give it a bit more Gas and it came back to life around 35-40Mph. It hasn't done it again since, but it does concern me... Any reason why this would be flaking on me? I've got the '97 GL Vulcan with the original Cluster still installed.

Saved by the Cross! Bled by a Taurus...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Vulcan I - '97 Silver Taurus GL
Vulcan II - '97 Forest Green Taurus GL
Vulcan III - '02 Tan Sable LS
SHO-HIS-Love - '96 Medium Willow SHO
gamefanatic is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-15-2005, 06:44 PM
Devoted Member
 
baby sho's Avatar
 
Join Date: Jan 2003
Location: Upstate, NY
Posts: 2,090
Rep Power: 0
 
Trader Score: 0 reviews
check the radio, does it work?

Make sure the fuse labled radio is not blown or loose, if its not, there could be somthing wrong with the speedo head.
baby sho is offline  
post #3 of 9 (permalink) Old 02-15-2005, 06:48 PM Thread Starter
Member
 
gamefanatic's Avatar
 
Join Date: Apr 2004
Posts: 396
Rep Power: 0
 
Trader Score: 0 reviews
The radio is working. Is there a sensor or something that controls the Speedo that I should look at or is this a mechanical speedometer?

Saved by the Cross! Bled by a Taurus...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Vulcan I - '97 Silver Taurus GL
Vulcan II - '97 Forest Green Taurus GL
Vulcan III - '02 Tan Sable LS
SHO-HIS-Love - '96 Medium Willow SHO
gamefanatic is offline  
post #4 of 9 (permalink) Old 02-15-2005, 07:27 PM
Devoted Member
 
baby sho's Avatar
 
Join Date: Jan 2003
Location: Upstate, NY
Posts: 2,090
Rep Power: 0
 
Trader Score: 0 reviews
Quote:
Originally posted by gamefanatic@Feb 15 2005, 08:48 PM
The radio is working. Is there a sensor or something that controls the Speedo that I should look at or is this a mechanical speedometer?
it is sensor driven, not cable.

So you choices are now faulty sensor, speedo head or wiring. If it "jumps" sometimes, most likley the speedo sensor, mine went bad and did the ame thing....not too har to fix.

Brad
baby sho is offline  
post #5 of 9 (permalink) Old 02-15-2005, 10:58 PM
Devoted Member
 
Join Date: Jul 2004
Location: Brantford, Ontario, Canada
Posts: 3,686
Rep Power: 0
 
Trader Score: 0 reviews
Send a message via MSN to Nidan
I believe the signal for the speedo is taken from the VSS or vehicle speed sensor mounted on the tranny. If the car has ABS, it also uses the wheel speed signals for the speedo. Some SHO owners have a problem with this system (my boss is one of them) where the speedo goes back to zero once they hit 140 kph (i think). Some weird thing in the ABS module that does it, and only on certain gen 3 SHO's.

I have a tendancy to wear my mind on my sleeve. I have a history of losing my shirt.

- Barenaked Ladies
(it suits me so well sometimes, heh)
Nidan is offline  
post #6 of 9 (permalink) Old 02-15-2005, 11:57 PM
Devoted Member
 
thejcode's Avatar
 
Join Date: Aug 2004
Location: Chassell, MI.
Posts: 4,482
Rep Power: 0
 
Trader Score: 0 reviews
Send a message via MSN to thejcode
I'd say its the VSS. Mine did the EXACT same thing. wouldnt work til about 30-40 and was fine. start sometimes, till lot of the time, till almost all the time, to now its dead. cruise control has been out for awhile now. So my vss is bad or dead. Radio and everything else work and all known fuses are good.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Sold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1996 Sable GS;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
New Ride as of Apr 4, 07:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Every Option). If I wanted a hummer I would ask your sister (82k Miles as of July 08) Now her mom's.
New Ride as of July 20, 07:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mods: Pioneer P7800MP (75k Miles as of March 09)
New Ride as of July 23, 08:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(53k Miles as of March 09)
New Ride as of April 24, 09:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(153k Miles as of April 09)
thejcode is offline  
post #7 of 9 (permalink) Old 02-16-2005, 03:48 PM Thread Starter
Member
 
gamefanatic's Avatar
 
Join Date: Apr 2004
Posts: 396
Rep Power: 0
 
Trader Score: 0 reviews
Yeah that was one of the things I was worried about is if it were to go out while I had Cruise Control on... Would the car just start to take off like a bullet (Green one at that) or would it only affect my ability to know how fast I am going??

Saved by the Cross! Bled by a Taurus...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Vulcan I - '97 Silver Taurus GL
Vulcan II - '97 Forest Green Taurus GL
Vulcan III - '02 Tan Sable LS
SHO-HIS-Love - '96 Medium Willow SHO
gamefanatic is offline  
post #8 of 9 (permalink) Old 02-16-2005, 05:53 PM
Devoted Member
 
Join Date: Jan 2005
Location: Vancouver, BC
Posts: 1,321
Rep Power: 0
 
Trader Score: 0 reviews
Send a message via AIM to holedigger
Quote:
Originally posted by gamefanatic@Feb 16 2005, 04:48 PM
Yeah that was one of the things I was worried about is if it were to go out while I had Cruise Control on...* Would the car just start to take off like a bullet (Green one at that) or would it only affect my ability to know how fast I am going??
If the difference between the current speed and the cruise control set speed is greater than 16km/h, the cruise control will automatically disengage. The same would happen if the VSS signal was lost for any reason, so not to worry.

It seems hot in the valley of Taurus...
holedigger is offline  
post #9 of 9 (permalink) Old 02-16-2005, 05:57 PM Thread Starter
Member
 
gamefanatic's Avatar
 
Join Date: Apr 2004
Posts: 396
Rep Power: 0
 
Trader Score: 0 reviews
Thank you for the info everyone!

Saved by the Cross! Bled by a Taurus...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Vulcan I - '97 Silver Taurus GL
Vulcan II - '97 Forest Green Taurus GL
Vulcan III - '02 Tan Sable LS
SHO-HIS-Love - '96 Medium Willow SHO
gamefanatic is offline  
Sponsored Links
Advertisement
 
Reply
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome