Speedometer Not Working... - Taurus Car Club of America : Ford Taurus Forum
Register Home Forums Active Topics Topic Finder Photos Members List Search Today's Posts Mark Forums Read Auto EscrowAuto Loans
TaurusClub.com is the premier Ford Taurus Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 02-15-2005, 07:08 PM   #1 (permalink)
Member
 
gamefanatic's Avatar
 
Member Number: 2711
Join Date: Apr 2004
Visit: My Garage
Posts: 396
Trader Score: 0 reviews
Rep Power: 0
gamefanatic has a little shameless behaviour in the past
Default

Yesterday I was doing some shopping. Everything was fine, but one time we got into the car and I started it up. Then I started to take off I noticed that the speedometer needle was not moving at all. Then I decided to give it a bit more Gas and it came back to life around 35-40Mph. It hasn't done it again since, but it does concern me... Any reason why this would be flaking on me? I've got the '97 GL Vulcan with the original Cluster still installed.
__________________
Saved by the Cross! Bled by a Taurus...
Vulcan I - '97 Silver Taurus GL
Vulcan II - '97 Forest Green Taurus GL
Vulcan III - '02 Tan Sable LS
SHO-HIS-Love - '96 Medium Willow SHO
gamefanatic is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-15-2005, 07:44 PM   #2 (permalink)
Devoted Member
 
baby sho's Avatar
 
Member Number: 533
Join Date: Jan 2003
Location: Upstate, NY
Visit: My Garage
Posts: 2,090
Trader Score: 0 reviews
Rep Power: 0
baby sho has a little shameless behaviour in the past
Default

check the radio, does it work?

Make sure the fuse labled radio is not blown or loose, if its not, there could be somthing wrong with the speedo head.
__________________
99' Black Taurus SE - Project BABY SHO v.2
Window Automation, Sattelite Vehicle Control, Dropped
SCT Micro Tuner/Flasher, 5-Speed Manual Tranny
SHO Front/Rear Disk Upgrade/Conversion, Bias Bypass
4 Corner Rear SFB's, Modified Tail's, Cold Air Intake....

98' Red E0 Contour SVT - Project SVT Tour'
Pioneer Touch Screen Navigation / DVD, Infinity Speakers
Borla Stainless Cat-Back, AEM True CAI, High Flow Y-Pipe
3L Hybrid w/ 3L Valves, Window Automation, Torsen LSD
Adjustable Koni Sport Kit Suspension, 17" FSVT Wheels....

97' F-150 Lariat
- Project Tow(the)Sho
Stock With All Options (Not For Long!)
baby sho is offline   Reply With Quote Quick reply to this message
Old 02-15-2005, 07:48 PM   #3 (permalink)
Member
 
gamefanatic's Avatar
 
Member Number: 2711
Join Date: Apr 2004
Visit: My Garage
Posts: 396
Trader Score: 0 reviews
Rep Power: 0
gamefanatic has a little shameless behaviour in the past
Default

The radio is working. Is there a sensor or something that controls the Speedo that I should look at or is this a mechanical speedometer?
__________________
Saved by the Cross! Bled by a Taurus...
Vulcan I - '97 Silver Taurus GL
Vulcan II - '97 Forest Green Taurus GL
Vulcan III - '02 Tan Sable LS
SHO-HIS-Love - '96 Medium Willow SHO
gamefanatic is offline   Reply With Quote Quick reply to this message
Old 02-15-2005, 08:27 PM   #4 (permalink)
Devoted Member
 
baby sho's Avatar
 
Member Number: 533
Join Date: Jan 2003
Location: Upstate, NY
Visit: My Garage
Posts: 2,090
Trader Score: 0 reviews
Rep Power: 0
baby sho has a little shameless behaviour in the past
Default

Quote:
Originally posted by gamefanatic@Feb 15 2005, 08:48 PM
The radio is working. Is there a sensor or something that controls the Speedo that I should look at or is this a mechanical speedometer?
it is sensor driven, not cable.

So you choices are now faulty sensor, speedo head or wiring. If it "jumps" sometimes, most likley the speedo sensor, mine went bad and did the ame thing....not too har to fix.

Brad
__________________
99' Black Taurus SE - Project BABY SHO v.2
Window Automation, Sattelite Vehicle Control, Dropped
SCT Micro Tuner/Flasher, 5-Speed Manual Tranny
SHO Front/Rear Disk Upgrade/Conversion, Bias Bypass
4 Corner Rear SFB's, Modified Tail's, Cold Air Intake....

98' Red E0 Contour SVT - Project SVT Tour'
Pioneer Touch Screen Navigation / DVD, Infinity Speakers
Borla Stainless Cat-Back, AEM True CAI, High Flow Y-Pipe
3L Hybrid w/ 3L Valves, Window Automation, Torsen LSD
Adjustable Koni Sport Kit Suspension, 17" FSVT Wheels....

97' F-150 Lariat
- Project Tow(the)Sho
Stock With All Options (Not For Long!)
baby sho is offline   Reply With Quote Quick reply to this message
Old 02-15-2005, 11:58 PM   #5 (permalink)
Devoted Member
 
Member Number: 3350
Join Date: Jul 2004
Location: Brantford, Ontario, Canada
Visit: My Garage
Posts: 3,686
Trader Score: 0 reviews
Rep Power: 0
Nidan has a little shameless behaviour in the past
Send a message via MSN to Nidan
Default

I believe the signal for the speedo is taken from the VSS or vehicle speed sensor mounted on the tranny. If the car has ABS, it also uses the wheel speed signals for the speedo. Some SHO owners have a problem with this system (my boss is one of them) where the speedo goes back to zero once they hit 140 kph (i think). Some weird thing in the ABS module that does it, and only on certain gen 3 SHO's.
__________________
I have a tendancy to wear my mind on my sleeve. I have a history of losing my shirt.

- Barenaked Ladies
(it suits me so well sometimes, heh)
Nidan is offline   Reply With Quote Quick reply to this message
Old 02-16-2005, 12:57 AM   #6 (permalink)
Devoted Member
 
thejcode's Avatar
 
Member Number: 3540
Join Date: Aug 2004
Location: Chassell, MI.
Visit: My Garage
Posts: 4,482
Trader Score: 0 reviews
Rep Power: 0
thejcode has a little shameless behaviour in the past
Send a message via MSN to thejcode
Default

I'd say its the VSS. Mine did the EXACT same thing. wouldnt work til about 30-40 and was fine. start sometimes, till lot of the time, till almost all the time, to now its dead. cruise control has been out for awhile now. So my vss is bad or dead. Radio and everything else work and all known fuses are good.
__________________

Sold 1996 Sable GS; Dual Exhaust; Spoiler w/60led brake light; Glow Gauges; Fog/Driving combo lights; 150,000 miles on Friday the 13'th, July 2007.
New Ride as of Apr 4, 07: '01 Jeep Grand Cherokee Limited (Every Option). If I wanted a hummer I would ask your sister (82k Miles as of July 08) Now her mom's.
New Ride as of July 20, 07: 1999 Contour SVT Mods: Pioneer P7800MP (75k Miles as of March 09)
New Ride as of July 23, 08: 2005 Audi A4 Quattro (53k Miles as of March 09)
New Ride as of April 24, 09: 2001 GMC Sonoma SLS X-Cab (153k Miles as of April 09)
thejcode is offline   Reply With Quote Quick reply to this message
Old 02-16-2005, 04:48 PM   #7 (permalink)
Member
 
gamefanatic's Avatar
 
Member Number: 2711
Join Date: Apr 2004
Visit: My Garage
Posts: 396
Trader Score: 0 reviews
Rep Power: 0
gamefanatic has a little shameless behaviour in the past
Default

Yeah that was one of the things I was worried about is if it were to go out while I had Cruise Control on... Would the car just start to take off like a bullet (Green one at that) or would it only affect my ability to know how fast I am going??
__________________
Saved by the Cross! Bled by a Taurus...
Vulcan I - '97 Silver Taurus GL
Vulcan II - '97 Forest Green Taurus GL
Vulcan III - '02 Tan Sable LS
SHO-HIS-Love - '96 Medium Willow SHO
gamefanatic is offline   Reply With Quote Quick reply to this message
Old 02-16-2005, 06:53 PM   #8 (permalink)
Devoted Member
 
Member Number: 4536
Join Date: Jan 2005
Location: Vancouver, BC
Visit: My Garage
Posts: 1,321
Trader Score: 0 reviews
Rep Power: 0
holedigger has a little shameless behaviour in the past
Send a message via AIM to holedigger
Default

Quote:
Originally posted by gamefanatic@Feb 16 2005, 04:48 PM
Yeah that was one of the things I was worried about is if it were to go out while I had Cruise Control on...* Would the car just start to take off like a bullet (Green one at that) or would it only affect my ability to know how fast I am going??
If the difference between the current speed and the cruise control set speed is greater than 16km/h, the cruise control will automatically disengage. The same would happen if the VSS signal was lost for any reason, so not to worry.
__________________
It seems hot in the valley of Taurus...
holedigger is offline   Reply With Quote Quick reply to this message
Old 02-16-2005, 06:57 PM   #9 (permalink)
Member
 
gamefanatic's Avatar
 
Member Number: 2711
Join Date: Apr 2004
Visit: My Garage
Posts: 396
Trader Score: 0 reviews
Rep Power: 0
gamefanatic has a little shameless behaviour in the past
Default

Thank you for the info everyone!
__________________
Saved by the Cross! Bled by a Taurus...
Vulcan I - '97 Silver Taurus GL
Vulcan II - '97 Forest Green Taurus GL
Vulcan III - '02 Tan Sable LS
SHO-HIS-Love - '96 Medium Willow SHO
gamefanatic is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:12 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2