Inside dome light won't go out - Taurus Car Club of America : Ford Taurus Forum
Register Home Forums Active Topics Topic Finder Photos Members List Search Today's Posts Mark Forums Read Auto EscrowAuto Loans
TaurusClub.com is the premier Ford Taurus Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 01-25-2013, 11:35 PM   #1 (permalink)
Member
 
caseitman's Avatar
 
Member Number: 24956
Join Date: Dec 2009
Location: Grand Junction, CO
Chapter: Northern
Drives: 1996 Ford Taurus SHO 3.4L V8
Visit: My Garage
Posts: 453
Trader Score: 1 reviews
Rep Power: 10
caseitman is an unknown quantity at this point
Default Inside dome light won't go out

hey guys, so when I unlock my car all the inside lights come on like they are supposed to do, but when I close the door and start the car the lights will stay on and it doesn't matter how long I drive they stay on. The idiot light for an open door is lite up on my dash. If I lock the car the lights will stay on for about 30 minutes before they finally shut off. Anyone know what itís doing and how to fix it? Thanks
caseitman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-25-2013, 11:41 PM   #2 (permalink)
Member
 
98SilverSable's Avatar
 
Member Number: 41989
Join Date: Sep 2011
Location: Jonesboro, GA
Chapter: Southeast
Drives: 1998 Mercury Sable LS Premium, 3.0L Duratec DOHC 24V V6
Visit: My Garage
Posts: 496
Trader Score: 0 reviews
Rep Power: 6
98SilverSable is an unknown quantity at this point
Default

most common fix is to spray WD40 in all your door latches. sometimes they dry out and will stick. And also make sure the light dimmer knob isn't all the way up, which will turn on all the interior lights and keep them on
__________________
"If I had money, I'll tell you what I'd do.... I'd go downtown and buy a Mercury or 2, crazy about a Mercury. Yeah, I'm crazy about a Mercury. I'm gonna buy me a Mercury and cruise it up and down the road!"

- Alan Jackson - "Mercury Blues"

Facebook
98SilverSable is offline   Reply With Quote
Old 01-26-2013, 09:15 AM   #3 (permalink)
Junior Member
 
Member Number: 36770
Join Date: May 2011
Location: Minneapolis, MN
Chapter: Midwest
Drives: 1999 Merc Sable GS 3.0L OHV Vulcan V6 engine 155555 miles
Visit: My Garage
Posts: 57
Trader Score: 0 reviews
Rep Power: 7
JBsable99 is an unknown quantity at this point
Default

Yeah WD40 should fix that up for a while. I've had to do it a few times. Getting some lock cylinder grease would be better in my opinion.
JBsable99 is offline   Reply With Quote
Old 01-26-2013, 10:04 AM   #4 (permalink)
Crazy Devoted Member
 
Member Number: 10865
Join Date: Dec 2006
Visit: My Garage
Posts: 12,118
Trader Score: 1 reviews
Rep Power: 51
sheila is a glorious beacon of lightsheila is a glorious beacon of light
Default

Follow the wd-40 with white lithium grease spray. Both available for cheap at walmart.
sheila is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:37 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2