Sluggish Acceleration - Taurus Car Club of America : Ford Taurus Forum
Register Home Forums Active Topics Topic Finder Photos Members List Search Today's Posts Mark Forums Read Auto EscrowAuto Loans
TaurusClub.com is the premier Ford Taurus Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 01-21-2013, 09:32 AM   #1 (permalink)
Junior Member
 
Member Number: 52413
Join Date: Jan 2013
Chapter: Northeast
Drives: 2001 Taurus SES 3.0 V6
Visit: My Garage
Posts: 1
Trader Score: 0 reviews
Rep Power: 0
thejadams72 is an unknown quantity at this point
Default Sluggish Acceleration

2001 Taurus has very sluggish acceleration. idles perfect. Just bought for a great deal, Im thinking fuel injector or fuel filter. Any ideas. It accelerates very slowly while sometimes making a clicking sound. The previous owner admits to running it out of gas. He states the car ran perfectly before running out of gas and after he refilled the problem started.
thejadams72 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-21-2013, 09:35 AM   #2 (permalink)
Emeritus Staff Member
 
The White Falcon's Avatar
 
Member Number: 51308
Join Date: Nov 2012
Location: Your business, it is not.
Chapter: Please Select a Region:
Drives: .
Visit: My Garage
Posts: 9,103
Trader Score: 0 reviews
Rep Power: 37
The White Falcon is a splendid one to beholdThe White Falcon is a splendid one to behold
Default

Quote:
Originally Posted by thejadams72 View Post
2001 Taurus has very sluggish acceleration. idles perfect. Just bought for a great deal, Im thinking fuel injector or fuel filter. Any ideas. It accelerates very slowly while sometimes making a clicking sound. The previous owner admits to running it out of gas. He states the car ran perfectly before running out of gas and after he refilled the problem started.
Try running some injector/fuel system cleaner through it. Which 3.0 do you have?
__________________
Bradley.
Holly: 2003 Ford Taurus SES Deluxe, Duratec/AX4N, spoiler, moonroof, OEM Centennials, JBL Audio system, other enhancements. April 2014 COTM winner.


See the details here.

Life at its best is a creative synthesis of opposites in fruitful harmony. Martin Luther King, Jr.
But...it was so artistically done. Grand Admiral Thrawn.
The White Falcon is offline   Reply With Quote
Old 01-21-2013, 10:04 AM   #3 (permalink)
Member
 
Member Number: 42637
Join Date: Oct 2011
Location: Florida
Chapter: Southeast
Drives: Mazda Protege 00 use to drive 96 Taurus OHV
Visit: My Garage
Posts: 294
Trader Score: 0 reviews
Rep Power: 7
peterf1992 is an unknown quantity at this point
Default

fuel filter could be clogged up because car runed out out gas and sucking up all the dirt instead of gas change the fuel filter and run some good quality fuel injector cleaner or just get gas at a chevron.
peterf1992 is offline   Reply With Quote
Old 01-21-2013, 01:27 PM   #4 (permalink)
Technical Advisor
 
behlinla's Avatar
 
Member Number: 14275
Join Date: Dec 2007
Location: Wisconsin
Chapter: Midwest
Drives: A blue car
Visit: My Garage
Posts: 7,507
Trader Score: 0 reviews
Rep Power: 80
behlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond repute
Default

Change the fuel filter and check the fuel pressure while revving the engine to make sure it doesn't drop.
behlinla is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:12 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2