P0340 code keeps returning - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 01-02-2013, 10:26 AM Thread Starter
Junior Member
 
Join Date: Jan 2013
Location: Plymouth, MI
Chapter: Midwest
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
P0340 code keeps returning

Hey all,

Long time reader, first time poster here. 2002 Taurus with the Vulcan engine. I have replaced the CPS, complete sensor/synchro assembly twice in the past year due to P0340 codes, and now it's back again. Son's car; he says it occasionally runs rough, has stalled once or twice, and the engine revs on its own. Anyone have this issue? I can't figure out why it keeps coming back. I'm sure I installed it correctly, otherwise it wouldn't run fine for six months. I've rebuilt multiple engines in my years and if I can remove and install a distributor correctly, then I figure I can do the same with the CPS, especially with the alignment tool. Lifetime warranty on the part so no $$ put out but it's a pain in the butt. Any ideas? Thanks in advance!
Andy
HandyAndy2112 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-02-2013, 11:13 AM
Technical Advisor
 
Join Date: Feb 2007
Location: Milwaukee, WI
Chapter: Midwest
Year: 2005
Model: Ford Taurus
Engine: 3.0L 24v Duratec V6
Posts: 5,692
Rep Power: 71
     
Trader Score: 0 reviews
What brand replacement did you use? Hopefully Motorcraft. Parts store brands are horrible. Not uncommon to see them bad out of the box.

05 Taurus SEL Duratec - my daily driver
04 Taurus SES Duratec - wifes car
95 Taurus GL Vulcan winter car
Toy #1 - 86 Tbird 5.0 (original owner) - LOTS of mods
Toy #2 - 88 Tbird Turbo Coupe - LOTS of mods
67 Honda 450 Super Sport - completely customized
Jeff K is offline  
post #3 of 5 (permalink) Old 01-02-2013, 11:27 AM Thread Starter
Junior Member
 
Join Date: Jan 2013
Location: Plymouth, MI
Chapter: Midwest
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
I'm going to have to pull the receipt when I get home to be sure, but as a rule I only buy good name brand parts-Standard Ignition, Moog, Monroe, etc. You get what you pay for. I got these from NAPA, and they do have the lifetime warranty but I know that doesn't necessarily mean good quality. I remember originally considering the Dorman unit since I've had good luck with their parts but then I read a whole bunch of bad reviews on their CPS, so I know it's not a Dorman.
HandyAndy2112 is offline  
post #4 of 5 (permalink) Old 01-02-2013, 12:01 PM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 17,212
Rep Power: 81
   
Trader Score: 1 reviews
Andy, if it's a Balkamp from Napa, it's a Dorman.
sheila is offline  
post #5 of 5 (permalink) Old 01-02-2013, 12:31 PM Thread Starter
Junior Member
 
Join Date: Jan 2013
Location: Plymouth, MI
Chapter: Midwest
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
Now that you mentioned Balkamp, I'm pretty sure that's what I bought. Same as the Dorman, huh? That would explain a few things. Maybe I'll see if NAPA will credit me toward a Motorcraft and replace this PITA one more time.
Thanks for that info!
HandyAndy2112 is offline  
Sponsored Links
Advertisement
 
Reply
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome