Oil light blinking only when stopped??? - Taurus Car Club of America : Ford Taurus Forum
Reply
 
LinkBack Thread Tools
post #1 of 28 (permalink) Old 03-06-2012, 10:52 PM Thread Starter
Member
 
guitarEd182's Avatar
 
Join Date: Sep 2010
Location: Massachusetts
Chapter: Northeast
Posts: 294
Rep Power: 0
 
Trader Score: 0 reviews
Oil light blinking only when stopped???

so tammy has been doing this recently. before i changed my oil it started doing this and i changed it and it still does it. it only blinks during idle. doesnt matter what gear im in, park, drive, reverse... as long as im stopped. as soon as i hit the gas and move, it goes away. im so confused and annoyed.



took this video earlier today after ive had enough. i was kinda pissed so i said, f*** it, im gonna see what the forum guys say.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Tammy.
2002 LX
guitarEd182 is offline  
Sponsored Links
Advertisement
 
post #2 of 28 (permalink) Old 03-06-2012, 10:54 PM Thread Starter
Member
 
guitarEd182's Avatar
 
Join Date: Sep 2010
Location: Massachusetts
Chapter: Northeast
Posts: 294
Rep Power: 0
 
Trader Score: 0 reviews

couldnt figure out how to embed this. the youtube embed link didnt work.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Tammy.
2002 LX
guitarEd182 is offline  
post #3 of 28 (permalink) Old 03-06-2012, 10:55 PM Thread Starter
Member
 
guitarEd182's Avatar
 
Join Date: Sep 2010
Location: Massachusetts
Chapter: Northeast
Posts: 294
Rep Power: 0
 
Trader Score: 0 reviews
well it does it on its own when posting a link i guess.. lol blowing up my own thread here.

yeah ignore the orianthi background music... my woman left it on after i dropped her off right before i took the video lol

and ignore my angry f words haha


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Tammy.
2002 LX
guitarEd182 is offline  
post #4 of 28 (permalink) Old 03-07-2012, 12:38 AM
Junior Member
 
Join Date: Jan 2012
Chapter: Southeast
Posts: 37
Rep Power: 0
 
Trader Score: 0 reviews
Your idle speed is dropping too low. Try cleaning the iac.
M-MAN is offline  
post #5 of 28 (permalink) Old 03-07-2012, 12:49 AM Thread Starter
Member
 
guitarEd182's Avatar
 
Join Date: Sep 2010
Location: Massachusetts
Chapter: Northeast
Posts: 294
Rep Power: 0
 
Trader Score: 0 reviews
idle speed??? im going 0mph...

u mean rpms???


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Tammy.
2002 LX
guitarEd182 is offline  
post #6 of 28 (permalink) Old 03-07-2012, 12:50 AM Thread Starter
Member
 
guitarEd182's Avatar
 
Join Date: Sep 2010
Location: Massachusetts
Chapter: Northeast
Posts: 294
Rep Power: 0
 
Trader Score: 0 reviews
annnndddd wtf is the iac


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Tammy.
2002 LX
guitarEd182 is offline  
post #7 of 28 (permalink) Old 03-07-2012, 01:13 AM
Junior Member
 
Join Date: Jan 2012
Chapter: Southeast
Posts: 37
Rep Power: 0
 
Trader Score: 0 reviews
Idle Air Control. Yes the rpm's. Looks like it's dropping to 6 or 7 hundred at times & that's way too low. The iac is a small round shiney valve that sit's on top of the engine at the back just a little left of where the accordian hose hooks to the throttle body from the air cleaner. It has a electrical connector & 2 8mm hexhead capscrews holding it on. Use the topic finder at the top for a tutorial.
M-MAN is offline  
post #8 of 28 (permalink) Old 03-07-2012, 02:10 AM
Devoted Member
 
Join Date: Apr 2003
Location: Virginia
Chapter: Southeast
Posts: 2,302
Rep Power: 38
 
Trader Score: 0 reviews
^+1 on the idle rpm looking low & cleaning the IAC. Remove & clean it with a plastic safe spray like CRC QD, or MAF sensor cleaner then remove the battery B- cable to wipe the KAM & go through this cold & warm idle relearn routine. Can Someone Tell Me How To Reset My Check Engine Light?

Are you using the specified viscosity oil & a Motorcraft filter?????

94 Taurus GL 3.8L PEP204A
99 Ranger 4dr 4.0L 5spd Auto
Payload & Tow Pkg

Details are trifles, but trifles make perfection & perfection is no trifle (Ben Franklin)
Our signature is a sign of a job completed, autograph your work with excellence.
pawpaw is offline  
post #9 of 28 (permalink) Old 03-07-2012, 04:54 AM
Devoted Member
 
SoNic67's Avatar
 
Join Date: Mar 2011
Location: SE Virginia
Chapter: Northeast
Posts: 2,329
Rep Power: 28
  
Garage
Trader Score: 0 reviews
Your engine is worn. At the low rpm, oil pump cannnot push enough oil (warm engine). IAC migh thelp raising the rpm's and therefore a littel the pressure.

But, even with 100rpm extra, it will be anyway lower than normal, even if the light is off. I would change to a higher grade oil (like 5W40 Shell Rotella) and higher flow oil filter (like K&N).

Low oil pressure (at idle) eats up your bearings.
SoNic67 is offline  
post #10 of 28 (permalink) Old 03-07-2012, 07:05 AM
WJC
Devoted Member
 
WJC's Avatar
 
Join Date: Sep 2008
Posts: 1,363
Rep Power: 24
 
Trader Score: 0 reviews
Quote:
Originally Posted by M-MAN View Post
Your idle speed is dropping too low. Try cleaning the iac.
No it isn't. Idle is right where it should be. Try replacing the oil sending unit, if that isn't the problem then the engine is worn.

"Spare the duct tape, spoil the job."
WJC is offline  
Sponsored Links
Advertisement
 
Reply
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome