2001 Ford Taurus (Rough Idle, Surge) - Page 2 - Taurus Car Club of America : Ford Taurus Forum
LinkBack Thread Tools
post #11 of 12 (permalink) Old 04-15-2011, 12:10 PM
Junior Member
Join Date: Apr 2011
Chapter: Northeast
Drives: 2003 Ford Taurus LX
Posts: 14
Rep Power: 0
Trader Score: 0 reviews
I am going through the same (idle miss when put into reverse or drive...fine otherwise) problem with my mother's car (2003 Taurus LX with Vulcan).

I installed new plugs (old ones had a huge gap), installed a new crank sensor (old one was nasty looking), installed new EGR, spray cleaned the MAF (with electrical spray) and cleaned the IAC valve.

Car still acts up. Smooth as silk in park. Can rev up and no misses. I just ordered a new TPS, DPFE and EGR vac solenoid (old one was dangling).

Any thoughts?
warment is offline  
Sponsored Links
post #12 of 12 (permalink) Old 01-21-2013, 10:30 AM
Junior Member
Join Date: Jan 2013
Chapter: Northeast
Drives: 2001Taurus LX 3.0
Posts: 1
Rep Power: 0
Trader Score: 0 reviews
idle surge

I have the same issue , could u please tell me what parts I need to get it fixed and a price range...thank u
leialg81 is offline  
Sponsored Links
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome