04 taurus stalls while driving - Taurus Car Club of America : Ford Taurus Forum
LinkBack Thread Tools
post #1 of 4 (permalink) Old 08-22-2010, 12:15 PM Thread Starter
Junior Member
Join Date: Aug 2010
Chapter: Northeast
Drives: 2004 SE vulcan V6
Posts: 1
Rep Power: 0
Trader Score: 0 reviews
04 taurus stalls while driving

Hi flolks. I'm Needing your ideas to try to solve

04 Taurus vulcan v6. purchased used..no warranty.
Problem(s) present in 2-ways. Both problems are intermittent.

1. after shutting off car a loud rapid clicking comes from under dash. all electrical accessories are disabled and car will not restart. Turn ignition key and silence except for the clicking which was already going on. Car will restart (sometimes) after sitting a while. Car can be jumped always.

2. After replacing alternator, car has now shut down completely at road speed. RPM meter quivers, dash lights flash then total shut down... Engine and electrical. dash lights flash back on after a few seconds. This has happened twice. Car restarted immediately after both episodes. problem #1 also continues after replacing the alternator.

Already done:

1. posts cleaned, clamps replaced, tested / replaced positive battery cable, tested / replaced alternator . Ford dealer has tested things / found nothing / can't replicate the problem.

Checked on previous Warranty work done under that VIN. Previous owner had warranty work done in 05 due to smoke coming from steering column.
wiring was part of the repair.

Thank you for any ideas. ..Even if it is where to go for more help. Car is at dealer as they try to solve it. so far, nothing. Huge safety concern obviously
jennysdad is offline  
Sponsored Links
post #2 of 4 (permalink) Old 08-22-2010, 06:38 PM
Senior Member
repairman54's Avatar
Join Date: Aug 2003
Location: Montague NJ
Drives: 03 Sable LS 24v
Posts: 740
Rep Power: 31
Trader Score: 0 reviews
Sounds like a bad ignition switch.
I had the idiot lights coming on and stalling issue erraticlly and the switch was my cure. NAPA had the switch in stock so that tells me it's a common thing.

"Some suffer from insanity, I choose to enjoy it"
'11 Tahoe
'09 Malilbu LS
'03 Sable LS 24v
'05 Sable 24v son's
'01 FLHR
Ski Doo's Sea Doo
Previously enjoyed vehicles
'07 Mustang GT 3 pedals
'88 Bull 170k rust & trans = junked
'94 Bull 160k sold while still running
'00 Sable wagon 24v 212k sold running fine
'89 S10 Blazer 4x4
'79 Dodge Van period customized
'75 Cordoba
'68 GTO
'68 Chrysler Newport 2dr
'67 Chevy Caprice 2dr
'67 Chevelle
'65 Bonneville
'65 Chevelle
'64 Olds Jetstar 88
repairman54 is offline  
post #3 of 4 (permalink) Old 08-23-2010, 03:24 PM
Junior Member
Join Date: Feb 2006
Posts: 1
Rep Power: 0
Trader Score: 0 reviews
My '03 Taurus had a similar problem. Had the battery and alternator and whatever the Autozone tester tests, but all checked out. I decided to just to get the battery replaced, it was only 2 yrs. and several mo old. Autozone prorated it and I paid the difference. I haven't had a problem since.
khmmc is offline  
post #4 of 4 (permalink) Old 10-04-2010, 02:43 PM
Junior Member
Join Date: Oct 2010
Chapter: Northeast
Drives: 2000 Taurus LX
Posts: 1
Rep Power: 0
Trader Score: 0 reviews
I'm having the exact same problem with my 98 LX. I've just replaced the ignition switch and that didn't resolve the issue at all.

It's definitely gotten worse the past week. Two or three months ago, it died once while underway, but it's been extremely erratic the past week or so.
randall1105 is offline  
Sponsored Links
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome