Rear Defroster Not Working - Taurus Car Club of America : Ford Taurus Forum
Register Home Forums Active Topics Topic Finder Photos Members List Search Today's Posts Mark Forums Read Auto EscrowAuto Loans
TaurusClub.com is the premier Ford Taurus Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 07-06-2005, 08:58 PM   #1 (permalink)
Member
 
Member Number: 2376
Join Date: Feb 2004
Visit: My Garage
Posts: 352
Trader Score: 0 reviews
Rep Power: 0
cmk0808 has a little shameless behaviour in the past
Default

My rear defroster is not working in my 1997 GL taurus. I think that the fuses are ok but i am going to put a test light to them and see if they are working. Is there a way to test a relay? Does anybody have any other suggestions. Right now it is downpouring here and i cant go outside to see what is going on. I have a remote starter in it and the rear defroster is hooked up to it. It has been hoooked up for a while and worked with no problems. When i activate it with the remote i hear the relay clicking so that is working. The switch on the radio panel doesnt do anything right now. I need this fxed immediately. If anyone has no idead other than the fuse and relay- i will ahve to bring it to the ford dealer.
cmk0808 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-06-2005, 09:03 PM   #2 (permalink)
Banned
 
Member Number: 4431
Join Date: Dec 2004
Location: N'awlins Louisiana
Visit: My Garage
Posts: 2,711
Trader Score: 0 reviews
Rep Power: 0
Robert L has a little shameless behaviour in the past
Send a message via MSN to Robert L
Default

Either the relay is bad or the switch.
Robert L is offline   Reply With Quote
Old 07-06-2005, 09:22 PM   #3 (permalink)
TCCA Staff (Retired)
 
rocketfoot's Avatar
 
Member Number: 4204
Join Date: Nov 2004
Location: Latrobe, PA
Chapter: Northeast
Drives: 96 Sable LS Premium, 13 Hemi Ram Crew Cab, 71 & 72 Mustangs
Visit: My Garage
Posts: 3,873
Trader Score: 0 reviews
Rep Power: 29
rocketfoot has a spectacular aura about
Default

Check the connections on the rear window element. Mine pop off all the time. (But I have a wagon with opening rear glass...it may be a bit different.)
__________________
rocketfoot is offline   Reply With Quote
Old 07-07-2005, 08:49 AM   #4 (permalink)
Member
 
Member Number: 5104
Join Date: Apr 2005
Visit: My Garage
Posts: 274
Trader Score: 0 reviews
Rep Power: 0
Grand Taurus 3 has a little shameless behaviour in the past
Send a message via MSN to Grand Taurus 3 Send a message via Yahoo to Grand Taurus 3
Default

I have the same problem with my 97 GL Taurus. It worked find untill I put in the aftermarket radio kit, then the rear defrost stopped working. I would fix the problem but here in Phoenix, who needs defrost.
__________________


Drive it like you stole it, when you get caught, blame it on the voices.



Grand Taurus 3 is offline   Reply With Quote
Old 07-07-2005, 08:51 AM   #5 (permalink)
mwt
Crazy Devoted Member
 
mwt's Avatar
 
Member Number: 1952
Join Date: Nov 2003
Location: Tulsa,OK
Visit: My Garage
Posts: 8,433
Trader Score: 0 reviews
Rep Power: 39
mwt is an unknown quantity at this point
Default

Quote:
Originally posted by Grand Taurus 3@Jul 7 2005, 07:49 AM
I have the same problem with my 97 GL Taurus. It worked find untill I put in the aftermarket radio kit, then the rear defrost stopped working. I would fix the problem but here in Phoenix, who needs defrost.
You have to wire the switch into the aftermarket kit.

Mike
__________________
"If you're a fan of getting into fat girls' pants, Dave Matthews Band CDs are the greatest invention since a ham on a fishing pole.

If I had known there was going to be a test I would have studied


94gl Vulcan totalled 4-01-04
99 LX FFV-purchased 4-17-04 totalled 5-17-06 untotalled on 9-2-07 and back on the road
New Paint coming soon
2000 SES Duratec Garage
2000 SEL Duratec this thing has everything but a spoiler
mwt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:30 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2