Battery Light Flashing - Taurus Car Club of America : Ford Taurus Forum
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 08-15-2016, 01:27 AM Thread Starter
Junior Member
 
Join Date: Apr 2009
Location: Southern California
Posts: 22
Rep Power: 0
 
Trader Score: 0 reviews
Post Battery Light Flashing

Hi I need some help, on my 99 been having a issue where the battery will discharge over a couple of days if I leave the car sit, I replaced the battery and when I checked voltage at idle was around 12.9 volts on new battery but it still goes dead over a couple of days if I don't drive. When I have tried to start and have to use my little portable booster starter I notice the cables are kinda hot, I can see one section of ground on fender is clean no corrosion. Also what I notice is the Theft light flashing and tonight I noticed the battery light flashing with the car off just sitting. This is a California car but has been with me in Michigan and now Indiana last four winters. I appreciate any and all help. Thanks
Jriver309 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 08-15-2016, 03:40 AM
Devoted Member
 
ice445's Avatar
 
Join Date: Oct 2014
Location: Toledo, OH
Chapter: Midwest
Year: 2006
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 3,002
Rep Power: 24
  
Garage
Trader Score: 1 reviews
Possibly a bad alternator diode that's shorted open and pulling current. Try disconnecting the alternator output cable from the stud and see if the problem stops. 12.9 is also way too low of a reading at idle (should be getting 14V), so it's very likely that the alt is bad.
Michele likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ice445 is offline  
post #3 of 13 (permalink) Old 08-15-2016, 09:45 AM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 18,810
Rep Power: 99
     
Trader Score: 1 reviews
Cassette stuck in the player?
sheila is offline  
 
post #4 of 13 (permalink) Old 08-15-2016, 09:53 AM
Play Nice or Don't Play

 
jag1959's Avatar
 
Join Date: Jun 2013
Chapter: Northeast
Year: 1998
Model: Ford Taurus SHO
Engine: 3.4L Yamaha V8
Posts: 13,178
Rep Power: 108
       
Trader Score: 0 reviews
From the Solutions to Common Problems forum:
Battery Draw Testing
jag1959 is offline  
post #5 of 13 (permalink) Old 08-15-2016, 09:54 AM
Crazy Devoted Member
 
Join Date: May 2011
Location: NY State
Chapter: Northeast
Year: 2003
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 7,535
Rep Power: 85
      
Garage
Trader Score: 0 reviews
Quote:
Originally Posted by ice445 View Post
Possibly a bad alternator diode that's shorted open and pulling current. Try disconnecting the alternator output cable from the stud and see if the problem stops. 12.9 is also way too low of a reading at idle (should be getting 14V), so it's very likely that the alt is bad.
Likely two issues at one time. Battery going down due to something being on or a bad Alt. Volts idling with things off should be 14.2-14.4 when first started. Should hold this with the headlights added with little to no change.

-chart-
chartmaker is online now  
post #6 of 13 (permalink) Old 08-16-2016, 10:05 PM Thread Starter
Junior Member
 
Join Date: Apr 2009
Location: Southern California
Posts: 22
Rep Power: 0
 
Trader Score: 0 reviews
Well this has taken a further twist, the light is on now all the time with the car off, but the car will not start, the starter does nothing, no clicking nothing. the battery is fully charged I used my charger on it. wondering if I have a combination of issues at same time now
Jriver309 is offline  
post #7 of 13 (permalink) Old 08-16-2016, 10:41 PM Thread Starter
Junior Member
 
Join Date: Apr 2009
Location: Southern California
Posts: 22
Rep Power: 0
 
Trader Score: 0 reviews
Quote:
Originally Posted by jag1959 View Post
From the Solutions to Common Problems forum:
Battery Draw Testing



Great video thank you that was something I needed to learn about
Jriver309 is offline  
post #8 of 13 (permalink) Old 09-01-2016, 03:59 PM Thread Starter
Junior Member
 
Join Date: Apr 2009
Location: Southern California
Posts: 22
Rep Power: 0
 
Trader Score: 0 reviews
Wanted to update, been out of the country for work and back to the car. I got the car to start by jumping the starter relay after the theft light would not stop flashing so I swapped relays it runs but battery light still on when car is off, a neighbor heling said there is a recall for this for the ignition switch, anyone hear of this before?? And also how do I disable the anti theft module
Jriver309 is offline  
post #9 of 13 (permalink) Old 09-08-2016, 12:18 PM Thread Starter
Junior Member
 
Join Date: Apr 2009
Location: Southern California
Posts: 22
Rep Power: 0
 
Trader Score: 0 reviews
Still looking for help on this




Quote:
Originally Posted by Jriver309 View Post
Wanted to update, been out of the country for work and back to the car. I got the car to start by jumping the starter relay after the theft light would not stop flashing so I swapped relays it runs but battery light still on when car is off, a neighbor heling said there is a recall for this for the ignition switch, anyone hear of this before?? And also how do I disable the anti theft module
Jriver309 is offline  
post #10 of 13 (permalink) Old 09-08-2016, 01:05 PM
Exalted Grand Poobah
 
Lgbpop's Avatar
 
Join Date: Mar 2006
Location: Fort Myers, Florida USA
Chapter: Southeast
Year: 1990
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 4,642
Rep Power: 67
    
Trader Score: 0 reviews
You don't disable the antitheft system, it's too fully integrated into the car's electrical system. I've seen them flash before in Fords with insufficient start voltage.Also, leaving a new battery hooked up when your car is in this condition is gonna ruin a perfectly-good battery. Call Ford about recalls: I never heard of this one myself.

Have you had that alternator tested yet?

Cancer sucks. Cancer post-op is almost worse than the cancer. Best part is, being alive to b*tch about it!

************************************************** *****************************

2016 Q1 Car of the Quarter
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lgbpop is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
200 Ford Taurus SES U Engine, Battery Light Saga connordo Maintenance and Repair 0 07-08-2015 07:30 PM
Check Engine light: Check the battery! Brcobrem Maintenance and Repair 10 07-16-2014 02:00 PM
Battery Light on ohio_grad_06 Maintenance and Repair 22 05-27-2014 08:29 PM
Help Please Battery Light, High RPMs, Stalls TheBassMekanik Maintenance and Repair 5 11-05-2013 10:15 PM
URGENT! Battery light ON = charging?? tripslipfall Maintenance and Repair 15 07-10-2013 05:01 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome