Battery Light Flickering - Taurus Car Club of America : Ford Taurus Forum

Reply
 
LinkBack Thread Tools
post #1 of 12 (permalink) Old 09-01-2010, 09:35 AM Thread Starter
Junior Member
 
Join Date: Aug 2010
Chapter: Southeast
Posts: 38
Rep Power: 0
 
Trader Score: 0 reviews
Battery Light Flickering

This has been happening since I got my car about a year and a half ago. The battery light, with no pattern, rhyme, or reason, will randomly come on, stay solid and/or flicker, then go off. My battery is new. My mechanic and my own personal findings say my alternator is fine at 14v.

What else could it be?
mxgoldman is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 09-01-2010, 01:57 PM
Member
 
Join Date: Jun 2010
Location: Minnesota
Chapter: Midwest
Year: 2004
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 318
Rep Power: 13
 
Trader Score: 1 reviews
That's a long time for it to be doing that and to not have something finally fail, ie: battery, alternator, serp belt, etc. Perhaps it's just gremlins (the little furry ones, not the AMC variety)...

Kevin

Current stable
2004 Sable LS Prem DOHC
2001 Taurus SES DOHC
Retired:2000 Taurus SE, 1994 Sable GS, 1988 Taurus LX
Hornswaggle is offline  
post #3 of 12 (permalink) Old 09-01-2010, 06:33 PM
Member
 
Join Date: Apr 2008
Posts: 140
Rep Power: 0
 
Trader Score: 0 reviews
my car does the same thing and the dealership says it is a loose connection to the alternator.
chacemastaflex is offline  
post #4 of 12 (permalink) Old 09-01-2010, 06:34 PM
Member
 
Join Date: Apr 2008
Posts: 140
Rep Power: 0
 
Trader Score: 0 reviews
i mostly get it when i accelerate from a stop relatively fast. what cause mine to start this problem was bad motor mounts and when i would accelerate it would pull on the wires when the mounts were bad but i have since replaced the motor mounts but that is not on subject
chacemastaflex is offline  
post #5 of 12 (permalink) Old 09-02-2010, 07:19 AM
Crazy Devoted Member
 
Join Date: May 2005
Location: Miramichi, New Brunswick
Posts: 5,849
Rep Power: 37
 
Trader Score: 0 reviews
Battery Light Flickering, High Rpm. (information)

This is the cause in most of the cases of why the light flickers at higher RPM.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Life is a hard teacher, it gives you the test before it teaches you the lesson.

The Human race is governed by it's own imagination.

Please don't steal, the government can't stand the competition.
the_intimidator_02 is offline  
post #6 of 12 (permalink) Old 09-02-2010, 08:09 PM Thread Starter
Junior Member
 
Join Date: Aug 2010
Chapter: Southeast
Posts: 38
Rep Power: 0
 
Trader Score: 0 reviews
There's no pattern to the light.
mxgoldman is offline  
post #7 of 12 (permalink) Old 09-17-2010, 01:10 PM
Junior Member
 
Join Date: Feb 2010
Posts: 20
Rep Power: 0
 
Trader Score: 0 reviews
Smile Battery light flickering

I have the same problem and and I think I know what it is. Next time you are driving, see if it comes more or less when the A/C or defrost is on. I think it comes down to is that if the serpentine belt is slipping at all, then the alternator cannot do its job and as such the battery light comes on. The belt will slip more if it is worn out and also check the pulleys that the belts ride on. I found one of my pulleys with what look like cuts in it which is not doing the belt any good either.
dideyjohn is offline  
post #8 of 12 (permalink) Old 03-17-2012, 11:53 AM Thread Starter
Junior Member
 
Join Date: Aug 2010
Chapter: Southeast
Posts: 38
Rep Power: 0
 
Trader Score: 0 reviews
Pretty sure it's just gremlins. Been three years, no breakdown. Except that one time that I had heat going at full-blast, big ol' amp going, and the key in the ingition, but not running.

Last edited by mxgoldman; 03-17-2012 at 01:28 PM.
mxgoldman is offline  
post #9 of 12 (permalink) Old 03-17-2012, 12:24 PM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 17,579
Rep Power: 85
    
Trader Score: 1 reviews
^ Get a free elec. load test at a parts store.
sheila is offline  
post #10 of 12 (permalink) Old 05-28-2014, 01:10 PM
Junior Member
 
Join Date: May 2014
Chapter: Midwest
Posts: 93
Rep Power: 5
 
Trader Score: 0 reviews
Mine does this also. Just had the tensioner replaced. New battery, new alternator. Belt is nice and quiet, no slipping that I know of. Shop I just had it at says it could be 1 of 1000 different things and not to worry about it. I hate that my battery light comes on though. I think I'm going to check the fuses like the mega fuse and a few others and possibly replace them if they are cheap, otherwise, oh well, what are you going to do?

Anyone know where that battery light bulb is? Lol. I hate that battery light at times.
ohio_grad_06 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome