interior lights won't shut off - Taurus Car Club of America : Ford Taurus Forum
Register Home Forums Active Topics Topic Finder Photos Members List Search Today's Posts Mark Forums Read Auto EscrowAuto Loans
TaurusClub.com is the premier Ford Taurus Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 07-02-2011, 02:13 AM   #1 (permalink)
Junior Member
 
Member Number: 24587
Join Date: Dec 2009
Location: Freehold, NJ
Drives: 1993 Mercury Sable GS
Visit: My Garage
Posts: 9
Trader Score: 0 reviews
Rep Power: 0
Isagenix has a little shameless behaviour in the past
Default interior lights won't shut off

I have a 1993 sable gs and the interior lights will not shut off. To make it simple I just removed every bulb inside the car. I would love to have them work again though. The switch seems to work properly with the dash lights so I don't think that went bad. What kind of sensors or relays etc. control when they go on and off?
Isagenix is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-02-2011, 07:42 AM   #2 (permalink)
Member
 
84FordMan's Avatar
 
Member Number: 29961
Join Date: Jun 2010
Location: Gastonia, NC
Chapter: Southeast
Drives: 2003 Ford Taurus
Visit: My Garage
Posts: 374
Trader Score: 0 reviews
Rep Power: 10
84FordMan will become famous soon enough
Default

Check the door jamb switches.
__________________
- 2010 Hyundai Genesis Coupe 3.8 (DD) -
- 1994 Mazda B3000 receiving an SHO V6-
84FordMan is offline   Reply With Quote Quick reply to this message
Old 07-02-2011, 11:17 AM   #3 (permalink)
Devoted Member
 
snoopy2003taurus's Avatar
 
Member Number: 9615
Join Date: Aug 2006
Location: York, PA
Chapter: Northeast
Drives: 2003 Taurus SEL/GT DOHC
Visit: My Garage
Posts: 2,382
Trader Score: 0 reviews
Rep Power: 21
snoopy2003taurus will become famous soon enough
Send a message via MSN to snoopy2003taurus
Default

Quote:
Originally Posted by 84FordMan View Post
Check the door jamb switches.
X2.
__________________
snoopy2003taurus is offline   Reply With Quote Quick reply to this message
Old 07-02-2011, 01:37 PM   #4 (permalink)
I'm Watching You!
 
sousa632's Avatar
 
Member Number: 37681
Join Date: Jun 2011
Location: Forked River, NJ
Chapter: Northeast
Drives: 01 Sable Wagon Duratec
Visit: My Garage
Posts: 7,163
Trader Score: 1 reviews
Rep Power: 50
sousa632 has much to be proud ofsousa632 has much to be proud ofsousa632 has much to be proud of
Default

Quote:
Originally Posted by 84FordMan View Post
Check the door jamb switches.
Every car that I have had a door jamb switch go bad was the opposite of what the OP posted. Instead of them failing and leaving the lights ON..... they typically fail keeping the lights off.
__________________
John
'01 Sable LS Premium Wagon Duratec 'The Silver Bullet' , '98 Windstar 3.8, '04 Freestar Cargo 3.9
sousa632 is online now   Reply With Quote Quick reply to this message
Old 07-02-2011, 02:18 PM   #5 (permalink)
Member
 
84FordMan's Avatar
 
Member Number: 29961
Join Date: Jun 2010
Location: Gastonia, NC
Chapter: Southeast
Drives: 2003 Ford Taurus
Visit: My Garage
Posts: 374
Trader Score: 0 reviews
Rep Power: 10
84FordMan will become famous soon enough
Default

Quote:
Originally Posted by sousa632 View Post
Every car that I have had a door jamb switch go bad was the opposite of what the OP posted. Instead of them failing and leaving the lights ON..... they typically fail keeping the lights off.
Maybe from rust or debris jamming the switch inwards permanently, but the majority of door jamb switches and brake light switches all suffer from the same failure, the shaft or spring breaks inside the switch, which leaves the lights (interior or brake lights respectively) on at all times.
__________________
- 2010 Hyundai Genesis Coupe 3.8 (DD) -
- 1994 Mazda B3000 receiving an SHO V6-
84FordMan is offline   Reply With Quote Quick reply to this message
Old 07-02-2011, 03:32 PM   #6 (permalink)
Crazy Devoted Member
 
Member Number: 10865
Join Date: Dec 2006
Visit: My Garage
Posts: 13,090
Trader Score: 1 reviews
Rep Power: 59
sheila is a splendid one to beholdsheila is a splendid one to behold
Default

Does 93 have the old plunger style switch?
sheila is offline   Reply With Quote Quick reply to this message
Old 07-03-2011, 06:58 AM   #7 (permalink)
Junior Member
 
Member Number: 33867
Join Date: Jan 2011
Chapter: Northeast
Drives: '95 GL Wagon
Visit: My Garage
Posts: 53
Trader Score: 0 reviews
Rep Power: 0
Lil_Red_Wagon can only hope to improve
Default

Strange, I just came here to ask about the same thing.

'95 GL Wagon

Everything was fine until last night. Open door, lights (overhead, kneewell, cargo area) come on.

Enter car, close door, lights go off.

Key in ignition, rotate, lights come on as car starts. Lights stay on and will not go off. Drove several miles that way.

At destination, shut engine off, lights still on.

Open and close all doors including tailgate, lights remain on.

Pull Fuse #8, lights go off.

Reinsert Fuse #8, lights come back on.

Dashboard dimmer switch operates/dims dash and console courtesy lights as normal. Rotating in and out of detent which normally would turn interior lights on/off makes no difference.

I have Fuse #8 pulled for now, but that also kills the radio memory and clock.

Ideas?
Lil_Red_Wagon is offline   Reply With Quote Quick reply to this message
Old 07-03-2011, 09:59 AM   #8 (permalink)
Junior Member
 
Member Number: 33867
Join Date: Jan 2011
Chapter: Northeast
Drives: '95 GL Wagon
Visit: My Garage
Posts: 53
Trader Score: 0 reviews
Rep Power: 0
Lil_Red_Wagon can only hope to improve
Default

Checked all of the switches as best I could. Passenger front sticks, but in a way that would prevent the lights from coming on, not staying on.

Driver front works since the Key-in chime starts when the door is opened and stops when the door is closed.

Removed the tailgate mercury switch thinking it may be stuck. No change.

Keyless entry keypad works normally, but back light stays on there also.

Electrical schematic is a bit hard to follow across several pages, but I can't find too much else in common that I can easily check.
Lil_Red_Wagon is offline   Reply With Quote Quick reply to this message
Old 07-03-2011, 01:36 PM   #9 (permalink)
Crazy Devoted Member
 
Member Number: 10865
Join Date: Dec 2006
Visit: My Garage
Posts: 13,090
Trader Score: 1 reviews
Rep Power: 59
sheila is a splendid one to beholdsheila is a splendid one to behold
Default

Might try spraying plunger switches with wd-40?
sheila is offline   Reply With Quote Quick reply to this message
Old 07-03-2011, 02:33 PM   #10 (permalink)
Junior Member
 
Member Number: 24587
Join Date: Dec 2009
Location: Freehold, NJ
Drives: 1993 Mercury Sable GS
Visit: My Garage
Posts: 9
Trader Score: 0 reviews
Rep Power: 0
Isagenix has a little shameless behaviour in the past
Default

I checked the switches and cleaned them all up on the two front doors. Rear doors don't have them and I have a sedan. They door open chime comes on when I open the door and have the keys in the ingnition. When I shut the door it goes off. But the lights still stay one. I disconnected to the dimmer switch to try to rule that out and still, they stay on. The switches look like a littlw white plastic clip that sticks out a little. I have no idea if its stuck or how its suppose to move. Are there any other areas? Can I go in and disconnect them one by one to see if that would take care of it? Would they keep the lights on or off if they were disconnected?
Isagenix is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:30 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2