LED corner lights 2010 SHO - Taurus Car Club of America : Ford Taurus Forum
Register Home Forums Active Topics Topic Finder Photos Members List Search Today's Posts Mark Forums Read Auto EscrowAuto Loans
TaurusClub.com is the premier Ford Taurus Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-31-2012, 08:06 PM   #1 (permalink)
Junior Member
 
TonyTheTiger57's Avatar
 
Member Number: 43815
Join Date: Nov 2011
Location: Saint Louis MO
Chapter: Midwest
Drives: 2010 Ford Taurus SHO 3.5L TiVCT V6 Atlantis Green
Visit: My Garage
Posts: 83
Trader Score: 0 reviews
Rep Power: 6
TonyTheTiger57 is an unknown quantity at this point
Send a message via Yahoo to TonyTheTiger57
Default LED corner lights 2010 SHO

My LED corner lights are not currently working, I can't find a fuse description in the owners manual for these, What would they be called in the owners manual? Anyone know what fuse number it would be? I would imagine a fuse went out for both LED bars to be out... i know there is a chance they are burnt out since the SHO has almost 90K on it already. Any info is appreciated, I ALSO used the search feature and did not find any info.
__________________
2010 Taurus SHO Atlantis Green NON PP
TonyTheTiger57 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-07-2013, 08:13 PM   #2 (permalink)
Junior Member
 
TonyTheTiger57's Avatar
 
Member Number: 43815
Join Date: Nov 2011
Location: Saint Louis MO
Chapter: Midwest
Drives: 2010 Ford Taurus SHO 3.5L TiVCT V6 Atlantis Green
Visit: My Garage
Posts: 83
Trader Score: 0 reviews
Rep Power: 6
TonyTheTiger57 is an unknown quantity at this point
Send a message via Yahoo to TonyTheTiger57
Default

A follow up on this post since nobody responded, I changed my oil today since it finally broke 40 degrees.. BOTH of my led lights just came unplugged? I plugged them back in and they work just fine. Thanks for the help on the situation.
__________________
2010 Taurus SHO Atlantis Green NON PP
TonyTheTiger57 is offline   Reply With Quote
Old 01-07-2013, 08:16 PM   #3 (permalink)
Technical Advisor
 
behlinla's Avatar
 
Member Number: 14275
Join Date: Dec 2007
Location: Wisconsin
Chapter: Midwest
Drives: A blue car
Visit: My Garage
Posts: 7,424
Trader Score: 0 reviews
Rep Power: 79
behlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond reputebehlinla has a reputation beyond repute
Default

Quote:
Originally Posted by TonyTheTiger57 View Post
BOTH of my led lights just came unplugged? I plugged them back in and they work just fine.
Did they click when you pushed them in? Do you think they just didn't push them on all the way at the factory?
behlinla is offline   Reply With Quote
Old 01-07-2013, 08:32 PM   #4 (permalink)
Devoted Member
 
mjhpadi's Avatar
 
Member Number: 43818
Join Date: Nov 2011
Location: Central Pennsylvania
Chapter: Northeast
Drives: 2010 Taurus SHO
Visit: My Garage
Posts: 1,246
Trader Score: 0 reviews
Rep Power: 9
mjhpadi has a spectacular aura about
Default

Sorry, just say this post, the LED lights are called: Supplemental Park Lamps.
__________________
2010 Ford Taurus SHO-Livernois 4+X Tune, Airaid CAI, Caliper Covers, Tinted Taillights, Tinted Headlights, LED Interior Lighting, LED Puddle Lamps and License Lights, SHO Hood Stripes, Rearranged Trunk Badging, 3 Bar MAP Sensor, 160 Evenflo Thermostat, V3 Triton Switchback LED Front Parking/Turn Signal
2004 Ford Explorer Limited-Wife's Tow Vehicle
1999 Mercury Sable LS-Our "Beatermobile"
1999 Ford Taurus SE Wagon-'Our Family Truckster"
mjhpadi is offline   Reply With Quote
Old 01-08-2013, 04:47 PM   #5 (permalink)
Junior Member
 
TonyTheTiger57's Avatar
 
Member Number: 43815
Join Date: Nov 2011
Location: Saint Louis MO
Chapter: Midwest
Drives: 2010 Ford Taurus SHO 3.5L TiVCT V6 Atlantis Green
Visit: My Garage
Posts: 83
Trader Score: 0 reviews
Rep Power: 6
TonyTheTiger57 is an unknown quantity at this point
Send a message via Yahoo to TonyTheTiger57
Default

Yeah, I am thinking they weren't clicked in all the way, they are a SOB to get them to "click". I am just glad it was something simple. It has been so cold lately and I have been working out of town and haven't had a chance to jack the car up. I figured it was just a fuse or the plug(s).
__________________
2010 Taurus SHO Atlantis Green NON PP
TonyTheTiger57 is offline   Reply With Quote
Old 01-08-2013, 11:22 PM   #6 (permalink)
Devoted Member
 
mjhpadi's Avatar
 
Member Number: 43818
Join Date: Nov 2011
Location: Central Pennsylvania
Chapter: Northeast
Drives: 2010 Taurus SHO
Visit: My Garage
Posts: 1,246
Trader Score: 0 reviews
Rep Power: 9
mjhpadi has a spectacular aura about
Default

The side running lamps on the side of the headlamps are also a pain to get at to change. I replaced the stock bulbs with LED bulbs and it was almost a 2 hour job to get at the bulbs to replace them....not easy to replace. Not sure it was worth the effort since you can't really tell them from regular bulbs...and FYI, the manual calls for these lights to be replaced with amber bulbs but the stock bulbs installed at manufacture are clear bulbs...in case you need or want to replace them. I would suggest using a clear or white bulb.
__________________
2010 Ford Taurus SHO-Livernois 4+X Tune, Airaid CAI, Caliper Covers, Tinted Taillights, Tinted Headlights, LED Interior Lighting, LED Puddle Lamps and License Lights, SHO Hood Stripes, Rearranged Trunk Badging, 3 Bar MAP Sensor, 160 Evenflo Thermostat, V3 Triton Switchback LED Front Parking/Turn Signal
2004 Ford Explorer Limited-Wife's Tow Vehicle
1999 Mercury Sable LS-Our "Beatermobile"
1999 Ford Taurus SE Wagon-'Our Family Truckster"
mjhpadi is offline   Reply With Quote
Old 01-09-2013, 09:24 AM   #7 (permalink)
Junior Member
 
TonyTheTiger57's Avatar
 
Member Number: 43815
Join Date: Nov 2011
Location: Saint Louis MO
Chapter: Midwest
Drives: 2010 Ford Taurus SHO 3.5L TiVCT V6 Atlantis Green
Visit: My Garage
Posts: 83
Trader Score: 0 reviews
Rep Power: 6
TonyTheTiger57 is an unknown quantity at this point
Send a message via Yahoo to TonyTheTiger57
Default

Why do they put out such very little light? I thought about putting in a 168 just to make them brighter
__________________
2010 Taurus SHO Atlantis Green NON PP
TonyTheTiger57 is offline   Reply With Quote
Old 01-09-2013, 11:25 AM   #8 (permalink)
Devoted Member
 
mjhpadi's Avatar
 
Member Number: 43818
Join Date: Nov 2011
Location: Central Pennsylvania
Chapter: Northeast
Drives: 2010 Taurus SHO
Visit: My Garage
Posts: 1,246
Trader Score: 0 reviews
Rep Power: 9
mjhpadi has a spectacular aura about
Default

They LED's look about the same as a regular bulb...I believe it is because of the amber color of the side lens itself. They look fine, just not sure it was worth all the work to change to an LED but since I have them in I will leave them, but if I ever replace them, I will get a white LED, not amber like I have in now...I was following the manual when I purchased the replacement LED bulbs, and didn't feel like going through the hassle of returning the amber and getting white, since I didn't realize the OEM bulb was clear until I removed it to replace it with the LED...so I just went with what I had.
__________________
2010 Ford Taurus SHO-Livernois 4+X Tune, Airaid CAI, Caliper Covers, Tinted Taillights, Tinted Headlights, LED Interior Lighting, LED Puddle Lamps and License Lights, SHO Hood Stripes, Rearranged Trunk Badging, 3 Bar MAP Sensor, 160 Evenflo Thermostat, V3 Triton Switchback LED Front Parking/Turn Signal
2004 Ford Explorer Limited-Wife's Tow Vehicle
1999 Mercury Sable LS-Our "Beatermobile"
1999 Ford Taurus SE Wagon-'Our Family Truckster"
mjhpadi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:38 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2