i need help - Taurus Car Club of America : Ford Taurus Forum
Reply
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 02-25-2013, 12:16 PM Thread Starter
Junior Member
 
Join Date: Feb 2013
Chapter: Northeast
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
i need help

I have a 2003 ford tar that the battery keeps going dead on me. I have had the battery check out and altternator check both are gud. But I can't understand y the battery keep dieing on me. I need help Please
andrewjbell is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 02-25-2013, 12:59 PM
Devoted Member
 
it'sthatcar's Avatar
 
Join Date: Aug 2012
Location: Minnesota
Chapter: Northern
Posts: 3,512
Rep Power: 19
 
Trader Score: 0 reviews
Have you checked to see if there is a light that stays on when the car is shut off? Like cab lights, trunk/cargo area light? How long is it between starts that the battery dies?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


David

2004 SEL Comfort ~ Shadow Grey Metallic ~ Mach upgrade with Pioneer speakers in the doors and Kenwood speakers in the rear deck ~ tinted windows ~ amber rear turn signal mod
it'sthatcar is offline  
post #3 of 11 (permalink) Old 02-25-2013, 03:38 PM Thread Starter
Junior Member
 
Join Date: Feb 2013
Chapter: Northeast
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
It happen fridayi got a boost off then Saturday I drove it Sunday I didn't drive it and.it Did it this morning
andrewjbell is offline  
post #4 of 11 (permalink) Old 02-25-2013, 06:46 PM
Sam
breeves002

 
Sam's Avatar
 
Join Date: Sep 2012
Location: St. Louis, MO
Chapter: Midwest
Year: 2008
Model: Mercury Sable
Engine: 3.5L Ti-VCT V6
Posts: 6,556
Rep Power: 93
       
Garage
Trader Score: 8 reviews
i need help

Well how do you know the battery is good? Did they load test it properly or just put this small thing on it and say its good?

I agree. Check for something staying on. If the battery truly is good, then something is draining it or it isn't charging correctly.


Sent from AutoGuide.com App

Sam

GET YOUR 2015 TCCA SHIRT HERE:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2008 Mercury Sable Premier
2014 Ford Focus Electric
1997 Mercury Grand Marquis GS
1991 BMW 850i E31 M70 V12
Moved On: 2000 Sable LS Premium Duratec
Sam is offline  
post #5 of 11 (permalink) Old 02-25-2013, 08:20 PM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 17,597
Rep Power: 85
    
Trader Score: 1 reviews
Welcome Andrew!
sheila is offline  
post #6 of 11 (permalink) Old 02-25-2013, 08:56 PM
Devoted Member
 
Roach's Avatar
 
Join Date: Nov 2010
Location: Concord, NC
Chapter: Southeast
Posts: 1,339
Rep Power: 15
 
Trader Score: 0 reviews
Something could be grounding out. Is there any custom wiring in it anywhere? [New interior/exterior lights, sound systems, etc..]


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2000 Taurus SE "Lady Hearse"
__1995 Taurus SHO "Organ Donor"

____1996 Thunderbird LX "Jade Phoenix"
Roach is offline  
post #7 of 11 (permalink) Old 02-25-2013, 09:47 PM
Exalted Grand Poobah

 
Lgbpop's Avatar
 
Join Date: Mar 2006
Location: Fort Myers, Florida USA
Chapter: Southeast
Year: 1990
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 4,458
Rep Power: 64
    
Trader Score: 0 reviews
Other concern is, how long do you run the car after jump-starting it? If it's down to the shopping center and back, you won't charge the battery up enough to do any good. It needs a good, deep overnight charge or a long drive.

Somehow, people since 2005 have "issues."

I love helping people with problems. Biggest problem many people have is, trying to change the English language. "Issues" are NOT problems.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lgbpop is offline  
post #8 of 11 (permalink) Old 02-25-2013, 10:13 PM
Devoted Member
 
Blkfordtaurusman's Avatar
 
Join Date: May 2011
Location: Chicago Il
Chapter: Midwest
Posts: 1,923
Rep Power: 15
 
Trader Score: 2 reviews
1) Could have corrosion Inside your battery clamps. Brush in side your battery clamps. 2) Your alternator charging wire may be fried out or burnt in the middle of the insulation and not transferring the charge. 3) your ground post could be corroded and compromised. 4)Are your battery clamps on loose? 5) perhaps a parasitic power draw from a bunch of endless sources? You may want to invest in a battery clamp that allows you to twist to disconnect the power until you successfully solve the problem. Google "disconnect type battery clamp". They are about $14. And if you have any accessories disconnect them.

Last edited by Blkfordtaurusman; 02-25-2013 at 10:15 PM.
Blkfordtaurusman is offline  
post #9 of 11 (permalink) Old 02-25-2013, 11:24 PM
Member
 
caseitman's Avatar
 
Join Date: Dec 2009
Location: Grand Junction, CO
Chapter: Northern
Posts: 480
Rep Power: 14
 
Trader Score: 1 reviews
I agree with everyone with the draining idea, maybe you didn't completely shut all your doors (pulled that one before) or maybe you have a loose ground coming off of your battery that isn't giving it a good enough ground charge
caseitman is offline  
post #10 of 11 (permalink) Old 02-26-2013, 06:22 PM Thread Starter
Junior Member
 
Join Date: Feb 2013
Chapter: Northeast
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
Yea I do have a sound system recently put in. Like 3 mnths. Ago
andrewjbell is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome